A partner account manager can help. Contact us today.

 Subscribe me your mailing list

[ERPSCAN-11-012] SAP NetWeaver Integration Directory — Multiple XSS

Application: SAP NetWeaver XI
Versions Affected: SAP NetWeaver XI
Vendor URL:
Bugs: XSS
Exploits: YES
Reported: 09.06.2010
Vendor response: 10.06.2010
Date of Public Advisory: 09.03.2011
Author: Dmitriy Evdokimov

SAP NetWeaver Integration Directory has multiple linked XSS vulnerabilities:

Business Risk
An attacker can use XSS vulnerability by sending a link on malicious script to an unaware user via an e-mail, messaging or social networks. The end user browser has no way to know that the script should not be trusted, and will execute the script. The malicious script can get an access to any cookies, session tokens, or other sensitive information retained by your browser and used with SAP web applications like Portal, CRM, SRM and others. This script can even rewrite the content of an HTML page. Thus, an attacker can gain access to user session and gain control on business-critical information which can be accessed by victim.