Close

HAVE QUESTIONS?

A partner account manager can help. Contact us today.

Subscribe me to your mailing list

[ERPSCAN-12-014] SAP Internet Sales – XSS

Application: SAP NetWeaver
Vendor URL: http://sap.com
Bugs: XSS
Risk: High
Exploits: YES
Reported: 08.04.2011
Vendor response: 08.04.2011
Date of Public Advisory: 17.02.2012
Reference: SAP Security Note 1583300

Description
SAP NetWeaver 7.0 Internet Sales (crm.b2b) has XSS vulnerability.

Business Risk
An attacker can use XSS vulnerability by sending a link on malicious script to an unaware user via e-mail, messaging or social networks. The end user browser has no way to know that the script should not be trusted, and will execute the script. The malicious script can get access to any cookies, session tokens, or other sensitive information retained by your browser and used with SAP web applications like Portal, CRM, SRM and others. This script can even rewrite the contents of an HTML page. Thus, an attacker can gain access to user session and gain control over business-critical information which can be accessed by victim.