Close

HAVE QUESTIONS?

A partner account manager can help. Contact us today.

[ERPSCAN-15-031] SAP MII – Encryption Downgrade vulnerability

Application: SAP MII
Vendor URL: http://www.sap.com
Bugs: Cryptographic issues
Reported: 05.09.2015
Vendor response: 06.09.2015
Date of Public Advisory: 20.11.2015
Reference: SAP Security Note 2240274
Author: Mathieu GELI (ERPScan)

VULNERABILITY INFORMATION
Class: Cryptographic issues
Impact: reading private information
Remotely Exploitable: Yes
Locally Exploitable: No
CVE Name: CVE-2015-8329
CVSS Information
CVSS Base Score: 2.1 / 10
CVSS Base Vector:

(N) (H) (S)
AV: Access Vector (Related exploit range) Network
AC: Access Complexity (Required attack complexity) High
Au: Authentication (Level of authentication needed to exploit) Single
C: Impact to Confidentiality Partial (P)
I: Impact to Integrity None (N)
A: Impact to Availability None (N)

Business risk
Base64 and DES are inherently insecure algorithms. A potential attacker will decrypt a password if he gets access to it.

Description
SAP MII allows Base64 and DES as an encryption algorithm.

VULNERABLE PACKAGES
SAP MII 12.2, 14.0, 15.0
Other versions are probably affected too, but they were not checked.

SOLUTIONS AND WORKAROUNDS
To correct this vulnerability, install SAP Security Note 2240274

TECHNICAL DESCRIPTION
SAP MII allows Base64 and DES algorithm selection at encryption configuration and export configuration screens.

Defense

To prevent this issue as well as a plethora of other vulnerabilities that may affect your systems, ERPScan provides the following services: